このページは、「ネットワークに興味があり、更にまだ一度もCisco製のスイッチやルータを触ったことのない方」向けの解説です。

スポンサーリンク

主に実機の設定に関して、開封後の初期設定からの流れを記載しています。

ここではCisco1812j を例に記載しています。

製品の筐体は以下の画像にあるような形状をしています。

①まずCisco1812j本体に電源ケーブルを挿し、電源スイッチをオンにします。
②続いて、以下の写真にあるる水色の専用コンソールケーブル(ロールオーバーケーブル)をコンソールポートに挿します。

多くの場合その対向側にUSBシリアルケーブルのDsub9ピンの口をつなぎ、ノートPC等から初期設定の操作を行うことになります。

③作業用の端末にてTeraterm等のターミナルソフトを開き、キーボードで「ENTER」キーをクリックします。(以下のような画面が表示されます)

本製品を開封後にログインした直後は、設定が何も入っていないのかというとそうではありません。
ある程度のデフォルト設定というものが入っています。
それを確認するためにまずは以下のコマンドを入力し、設定前のコンフィグを残しておくことをお勧めします。

router> enable
router# configure terminal
router(config)# hostname cisco_A
cisco_A(config)# exit
cisco_A#

router# show run

■Cisco 1812J の起動時のデフォルト設定

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
ip cef
!
ip ips po max-events 100
no ftp-server write-enable
!
interface BRI0
no ip address
shutdown
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface FastEthernet4
no ip address
shutdown
!
interface FastEthernet5
no ip address
shutdown
!
interface FastEthernet6
no ip address
shutdown
!
interface FastEthernet7
no ip address
shutdown
!
interface FastEthernet8
no ip address
shutdown
!
interface FastEthernet9
no ip address
shutdown
!
interface Vlan1
no ip address
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

基本的な初期設定

ここで述べている「基本的な初期設定」とは、設計、用途を問わずほぼ共通して事前に設定されるであろう設定部分を指しています。

 

コンソールの設定
(config)# line console 0
(config-line)# password ********
(config-line)# login

自動ログアウトしない
(config-line)# exec-timeout 0 0

SSHでの接続設定
(config)# line vty 0 4
(config-line)# password ********
(config-line)# transport input telnet
(config-line)# login 

コマンド入力中のメッセージ割り込み対策
(config-line)# logging synchronous

DNS問い合わせを無効化
(config)# no ip domain lookup

ブラウザからのアクセスを遮断
(config)# no ip http server

// DNSサーバ設定
(config)# ip name-server xxx.xxx.xxx.xxx
(config)# ip name-server xxx.xxx.xxx.xxx

 

FastEthernetインターフェイスにIPアドレスを設定します。

> enable
Password: xxxxx
# configure terminal
(config)# interface fastethernet 0/0
(config-if)# ip address 192.168.1.1 255.255.255.0
(config-if)# no shutdown(シャットダウン解除)
(config-if)# exit

・インターフェイスにコメントをつけます
(config-if)# description To:LAN

■Ciscoルータにおけるスタティックルートの追加

スタティックルートの追加はまず下記コマンドでルーティングをオンにします。

# configure terminal
(config)# ip routing

・スタティックルートを追加します。

(config)# ip route 172.16.0.0 255.255.255.0 192.168.1.254 (cisco_A , cisco_B)
(config)# ip route 192.168.1.0 255.255.255.0 172.16.0.254 (cisco_C , cisco_D)
(config)# exit

送信先へのルートが不明な場合に使用される特別経路情報をデフォルトルートと言います。デフォルトルートを利用するとIPアドレス、サブネットマスクともに0.0.0.0を使用します。

# configure terminal
(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.254
(config)# exit

※noをつけることによって設定を解除できます。

# configure terminal
(config)# no ip route 192.168.2.0 255.255.255.0 192.16.1.100
(config)# no ip route 192.168.3.0 255.255.255.0 192.16.1.200
(config)# exit

ルーティングテーブルの表示
# show ip route

 

この記事が気に入ったら
いいね ! しよう

スポンサーリンク
error: Content is protected !!